$ export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib/gcc/x86_64-unknown-openbsd7.3/11.2.0
$ export AUTOCONF_VERSION="2.71"
$ export AUTOMAKE_VERSION="1.16"
$ cd ~/src/emacs
$ git pull
$ gmake bootstrap
終わるまで時間がかかるので, 今日はコンパイルを走らせたまま区切りを付ける.
$ export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib/gcc/x86_64-unknown-openbsd7.3/11.2.0
$ export AUTOCONF_VERSION="2.71"
$ export AUTOMAKE_VERSION="1.16"
$ cd ~/src/emacs
$ git pull
$ gmake bootstrap
# sysmerge
# cd /dev
# ./MAKEDEV all
# cd /usr/xenocara
# make bootstrap
# make obj
# make build
# pkg_add -uv
$ uname -a
OpenBSD mybsd.local 7.3 GENERIC.MP#21 amd64
$ cd /usr/src
$ cvs -q up -Pd -A
$ cd /usr/xenocara
$ cvs -q up -Pd -A
$ cd /usr/ports
$ cvs -q -up -Pd -A
# sysupgrade -s
# cd /sys/arch/amd64/compile/GENERIC.MP
# make obj
# make config
# make && make install
# cd /usr/src
# make obj && make build
$ export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib/gcc/x86_64-unknown-openbsd7.3/11.2.0
$ export AUTOCONF_VERSION="2.71"
$ export AUTOMAKE_VERSION="1.16"
$ ./autogen.sh
$ ./configure \
'CFLAGS=-I/usr/include -I/usr/X11R6/include -I/usr/local/include' \
'LDFLAGS=-L/usr/lib -L/usr/X11R6/lib -L/usr/local/lib -lgccjit' \
--prefix=/usr/local \
--mandir=/usr/local/share/man \
--infodir=/usr/local/info \
--with-x-toolkit=athena \
--with-imagemagick \
--with-xaw3d \
--with-x \
--without-xim \
--with-xpm=ifavailable \
--with-native-compilation
$ git pull
$ gmake bootstrap
$ gmake check
# gmake install
M-x emacs-version
GNU Emacs 30.0.50 (build 1, x86_64-unknown-openbsd7.3,
X toolkit, cairo version 1.17.8, Xaw3d scroll bars) of 2023-08-02
# sysmerge # システム関連の各種ファイルのアップデート
# cd /dev/ && ./MAKEDEV all # デバイスファイルの作成
# cd /usr/xenocara
# make bootstrap
# make obj
# make build
# pkg_add -uv
$ uname -a
OpenBSD mybsd.local 7.3 GENERIC.MP#20 amd64
$ cd /usr/src
$ cvs -q up -Pd -A
$ cd /usr/xenocara
$ cvs -q up -Pd -A
$ cd /usr/ports
$ cvs -q -up -Pd -A
# sysupgrade -s
# cd /sys/arch/amd64/compile/GENERIC.MP
# make obj
# make config
# make && make install
# cd /usr/src
# make obj && make build
Waiting for Emacs...
*ERROR*: Wrong number of arguments: ((vterm--process eshell-preoutput-filter-functions t) (fn &optional next-buffer args) "Honor `with-editor-server-window-alist' (which see)." (let ((server-window (save-current-buffer (set-buffer (or next-buffer (current-buffer))) (if with-editor-mode (progn (setq with-editor-previous-winconf (current-window-configuration)))) (with-editor-server-window)))) (funcall fn next-buffer args))), 5
&optional next-buffer killed-one filepos this-frame-only
&optional next-buffer &rest args
--- with-editor.el.orig Mon Dec 5 02:20:39 2022
+++ with-editor.el Thu Jul 20 17:39:18 2023
@@ -532,7 +532,8 @@
server-window))
(defun server-switch-buffer--with-editor-server-window-alist
- (fn &optional next-buffer &rest args)
+ (fn &optional next-buffer killed-one filepos this-frame-only)
"Honor `with-editor-server-window-alist' (which see)."
(let ((server-window (with-current-buffer
(or next-buffer (current-buffer))
@@ -540,7 +541,7 @@
(setq with-editor-previous-winconf
(current-window-configuration)))
(with-editor-server-window))))
- (apply fn next-buffer args)))
+ (apply fn next-buffer killed-one filepos this-frame-only)))
(advice-add 'server-switch-buffer :around
#'server-switch-buffer--with-editor-server-window-alist)
$ export AUTOCONF_VERSION="2.71"
$ export AUTOMAKE_VERSION="1.16"
$ export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib/gcc/x86_64-unknown-openbsd7.3/11.2.0
$ git pull
$ ./autogen.sh
$ ./configure \
'CFLAGS=-I/usr/include -I/usr/X11R6/include -I/usr/local/include' \
'LDFLAGS=-L/usr/lib -L/usr/X11R6/lib -L/usr/local/lib -lgccjit' \
--prefix=/usr/local \
--mandir=/usr/local/share/man \
--infodir=/usr/local/info \
--with-x-toolkit=athena \
--with-imagemagick \
--with-xaw3d \
--with-x \
--without-xim \
--with-xpm=ifavailable \
--with-native-compilation
$ gmake bootstrap
$ gmake check
# gmake install
M-x emacs-version
GNU Emacs 30.0.50 (build 1, x86_64-unknown-openbsd7.3, X toolkit, cairo version 1.17.8, Xaw3d scroll bars) of 2023-07-04
# sysmerge
# cd /dev/ && ./MAKEDEV all
# cd /usr/xenocara
# make bootstrap
# make obj
# make build
# pkg_add -uv
$ uname -a
OpenBSD mybsd.local 7.3 GENERIC.MP#19 amd64
$ cd /usr/src
$ cvs -q up -Pd -A
$ cd /usr/xenocara
$ cvs -q up -Pd -A
$ cd /usr/ports
$ cvs -q -up -Pd -A
# sysupgrade -s
# cd /sys/arch/amd64/compile/GENERIC.MP
# make obj
# make config
# make && make install
# cd /usr/src
# make obj && make build