家studyをつづって
1
Ubuntu18.04で作成したCentOSのコンテナ上でApacheを動かして接続してみた。試していく中で、httpdのサービスを起動しようとすると、「Failed to get D-Bus connection: Operation not permitted」というエラーが出て実行できなかった。以下の手順は、自分の環境でhttpdサービスが起動できた手順を記載。1.imageの取得コンテナ上のOSはCentOS7を使用する。>docker pull centos:centos7※上記実行後はdocker imagesコマンドでイメージが取得できたことを確認できる。2.コンテナ起動コンテナを起動>docker run --privileged -d --name コンテナ名 centos:centos7 /sbin/initコンテナに接続>docker exec -it コンテナ名 /bin/bash※以降はコンテナ上の操作3.httpdのインストールと起動通常のhttpdのインストール>yum install httpd>systemctl start httpd起動まで確認できた時点で、一度コンテナを抜ける>Ctrl+P+Q4.現在のイメージを保存イメージの作成>docker commit 1-4で操作していたコンテナ名 レポジトリ名:タグ名もとのコンテナの削除>docker stop 1-4で操作していたコンテナ名>docker rm 1-4で操作していたコンテナ名5.作成したイメージでコンテナを起動新しいコンテナを4.で作成したイメージをもとに起動>docker run --privileged -d -p 8080:80 --name 新しいコンテナ名 4.で作ったレポジトリ名:タグ名※原因はわかっていないが、自分の環境で以下のように実行すると応答がなくなってしまうので、このような手順で行った。応答が帰らなくなったコマンド>docker run --privileged --name コンテナ名 -it -p 8080:80 centos:centos7 /bin/bashコンテナへ接続>docker exec -it 新しいコンテナ名 /bin/bash6.コンテナ上でhttpdの起動>systemctl start httpd上記実行後、ホスト側の端末のブラウザで、http://127.0.0.1:8080に接続するとapacheのテストページが表示される。
2019年02月11日
閲覧総数 2838