日々の記録

日々の記録

PR

×

キーワードサーチ

▼キーワード検索

サイド自由欄

2021.04.30
XML
カテゴリ: linux
ずいぶん前に購入した東芝製REGZA(Z9000)に接続しているHDDがいっぱいなので、容量の大きなものにしたかったのだが、新しいHDDを接続し、そこにすべてのファイルを転送するとなると、ものすごく時間がかかりそうなので、躊躇していた。


用いるのは、PC、旧HDD(2TB)、新HDD(4TB)とUbuntuのDVD。
まず、新HDDは、あらかじめREGZAに接続し、設定を終えておく。

そして、Ubuntu 18.04のDVDを持っていたので、DVDプレーヤー付きのPCで起動。
ここでは、UBUNTUのインストールは行わず、起動するだけ。
それに2台のHDDを接続。
ただ、なぜか旧HDDがマウントできず、can't read superblockなどとエラーが出る。

このエラーは、ubuntuのxfs_repairというコマンドで、回復できるらしいが、実際には、xfs_repairのバージョンが新しすぎて(あるいはregzaが古すぎて)使えなかった。


たまたまUbuntu 12.04のDVDも持っていたが、PCに入れても起動しない。
DVDが悪いのかもしれないと思って、生DVDが手元にないので、USBメモリでの起動を試す。
これには、Rufusというソフトを用いた。
Ubuntu 12.04のisoファイルをダウンロードし、RufusでUSBメモリに記録。

しかしながら、これでも起動しない。
別のマシンでも起動しない。
Ubuntu 12.04が古すぎて、マシンのCPUに対応していないということなのか?
最終的には、古いノートPCで起動した。

そこに、2台のHDDを接続。
/dev/sdd1 (旧HDD)
/dev/sde1 (新HDD)として、認識される。


# xfs_repair /dev/sdd1
を実行するも、エラーメッセージが出る。
-Lオプションをつけろ。ただし、なにかのファイルが壊れるという警告。

しばらく調査した。
CrystalDiskInfoを用いて警告が出たら、xfs_repairを使うべきではないという記事を見つけた。

# xfs_repair -L /dev/sdd1
うまくいったみたいで、旧HDDもマウントできた。

そのあとは、ubuntuのファイルマネジャー(nautilus)で、ファイルのコピー。
この際、隠しファイルを表示するに設定しておく。
nautilusの起動の際には、
#sudo nautilus
として、root権限での実行が必要となる。
私の場合は、一般ユーザーとしてnautilusを起動してしまってコピーできずに困った。結局、端末を開いて、sudo cpでコピーした。

このコピーには、時間がかかった。
progressというプログラムをインストールして観察したが、転送速度は、40MB/s程度。
旧HDDは、USB2なので仕方がない。
しかも、ノートPCもUSB3に対応しているかどうかも怪しい。
転送すべきファイル容量は1.5TB以上あったので、10時間以上かかる計算になる。
結局、それくらいかかった。

その後、umountコマンドで、HDDのアンマウント。
# sudo umount /media/......

そして、最後にやるのが、UUIDの書き換え。
# sudo xfs_admin -u /dev/sdd1 (旧HDD)
で、旧HDDのUUIDを調査。
UUID=????
と出る。

???の部分をコピーし、以下の???にペースト。
# sudo xfs_admin -U ??? /dev/sde1 (新HDD)
ここでのUは大文字。
これで新HDDに旧HDDと同じUUIDが書き込まれ、作業はすべて終わり。
新しいHDDをregzaに接続してみたが、きちんと動いているようだ。





お気に入りの記事を「いいね!」で応援しよう

最終更新日  2021.04.30 18:30:34


【毎日開催】
15記事にいいね!で1ポイント
10秒滞在
いいね! -- / --
おめでとうございます!
ミッションを達成しました。
※「ポイントを獲得する」ボタンを押すと広告が表示されます。
x
X

© Rakuten Group, Inc.
X
Design a Mobile Site
スマートフォン版を閲覧 | PC版を閲覧
Share by: