Collect Check Point SmartDefense logs

Supported in:

This document explains how to ingest Check Point SmartDefense logs to Google Security Operations using the Bindplane agent.

The parser extracts fields from Check Point SmartDefense syslog formatted logs. It uses grok and/or kv to parse the log message and then maps these values to the Unified Data Model (UDM). It also sets default metadata values for the event source and type.

Before you begin

Make sure you have the following prerequisites:

  • A Google SecOps instance
  • A Windows 2016 or later or Linux host with systemd
  • If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements
  • Privileged access to the Check Point SmartDefense management console or appliance

Get Google SecOps ingestion authentication file

  1. Sign in to the Google SecOps console.
  2. Go to SIEM Settings > Collection Agents.
  3. Download the Ingestion Authentication File.
  4. Save the file securely on the system where the Bindplane agent will be installed.

Get Google SecOps customer ID

  1. Sign in to the Google SecOps console.
  2. Go to SIEM Settings > Profile.
  3. Copy and save the Customer IDfrom the Organization Detailssection.

Install the Bindplane agent

Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.

Windows installation

  1. Open the Command Promptor PowerShellas an administrator.
  2. Run the following command:

      msiexec 
      
     / 
     i 
      
     "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" 
      
     / 
     quiet 
     
    

Linux installation

  1. Open a terminal with root or sudo privileges.
  2. Run the following command:

     sudo  
    sh  
    -c  
     " 
     $( 
    curl  
    -fsSlL  
    https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh ) 
     " 
      
    install_unix.sh 
    

Additional installation resources

For additional installation options, consult this installation guide .

Configure the Bindplane agent to ingest Syslog and send to Google SecOps

  1. Access the configuration file:

    • Locate the config.yaml file. Typically, it's in the /etc/bindplane-agent/ directory on Linux or in the installation directory on Windows.
    • Open the file using a text editor (for example, nano , vi , or Notepad).
  2. Edit the config.yaml file as follows:

      receivers 
     : 
      
     udplog 
     : 
      
     # Replace the port and IP address as required 
      
     listen_address 
     : 
      
     "0.0.0.0:514" 
     exporters 
     : 
      
     chronicle/chronicle_w_labels 
     : 
      
     compression 
     : 
      
     gzip 
      
     # Adjust the path to the credentials file you downloaded in Step 1 
      
     creds_file_path 
     : 
      
     '/path/to/ingestion-authentication-file.json' 
      
     # Replace with your actual customer ID from Step 2 
      
     customer_id 
     : 
      
    < customer_id 
    >  
     endpoint 
     : 
      
     malachiteingestion-pa.googleapis.com 
      
     # Add optional ingestion labels for better organization 
      
     log_type 
     : 
      
     'CHECKPOINT_SMARTDEFENSE' 
      
     raw_log_field 
     : 
      
     body 
      
     ingestion_labels 
     : 
     service 
     : 
      
     pipelines 
     : 
      
     logs/source0__chronicle_w_labels-0 
     : 
      
     receivers 
     : 
      
     - 
      
     udplog 
      
     exporters 
     : 
      
     - 
      
     chronicle/chronicle_w_labels 
     
    
    • Replace the port and IP address as required in your infrastructure.
    • Replace <CUSTOMER_ID> with the actual Customer ID.
    • Update /path/to/ingestion-authentication-file.json to the file path where the authentication file was saved in Step 1.

Restart the Bindplane agent to apply the changes

  1. To restart the Bindplane agent in Linux, run the following command:

     sudo  
    systemctl  
    restart  
    observiq-otel-collector 
    
  2. To restart the Bindplane agent in Windows, you can either use the Servicesconsole or enter the following command:

     net stop observiq-otel-collector && net start observiq-otel-collector 
    

Configure Syslog forwarding on Check Point SmartDefense

Step 1: Create Log Exporter/SIEM Object in SmartConsole

  1. Sign in to the Check Point SmartConsole.
  2. Go to Objects > More object types > Server > Log Exporter/SIEM.
  3. Click Newto create a new Log Exporter object.
  4. Provide the following configuration details:
    • Object Name: Enter a descriptive name (for example, Google SecOps Bindplane ).
    • Export Configuration: Select Enabled.
    • Target Server: Enter the Bindplane agent IP address.
    • Target Port: Enter 514 (or your configured Bindplane agent port number).
    • Protocol: Select UDP.
  5. Go to the Data Manipulationpage.
  6. Provide the following configuration details:
    • Format: Select Common Event Format (CEF).
    • Timezone: Select UTC timezone for universal consistency across systems.
  7. Click OKto save the configuration.

Step 2: Configure Management Server or Log Server

  1. In SmartConsole, go to Gateways & Servers.
  2. Open your Management Serveror Dedicated Log Server/SmartEvent Serverobject.
  3. Go to Logs > Export.
  4. Click +and select the Log Exporter/SIEM object you configured earlier.
  5. Click OK.

Step 3: Install Database Policy

  1. From the top menu, click Install > Install database.
  2. Select all objects.
  3. Click Install.

Step 4: Verify Log Export Configuration

  1. Connect to the command line on the Management Server/Log Server.
  2. Log in to Expert mode.
  3. Run the following command to verify the configuration:

     cp_log_export  
    show 
    
  4. To restart the Log Exporter if needed:

     cp_log_export  
    restart 
    

UDM mapping table

Log Field UDM Mapping Logic
message
about Mapped: CEF: about
deviceNtDomain
about.administrative_domain Renamed/mapped
deviceExternalId
about.asset.asset_id Directly mapped
device_product
about.asset.asset_id Directly mapped
device_vendor
about.asset.asset_id Directly mapped
fileHash
about.file.full_path Directly mapped
filePath
about.file.full_path Renamed/mapped
_hash
about.file.sha256 Renamed/mapped
fileHash
about.file.sha256 Renamed/mapped
fsize
about.file.size Renamed/mapped
dvchost
about.hostname Renamed/mapped
ips
about.ip Merged
message
about.ip Mapped: CEF: ips
dvc_mac
about.mac Mapped: slot mac_address
dvcmac
about.mac Merged
mac_address
about.mac Merged
message
about.mac Mapped: CEF: mac_address , CEF: dvcmac
deviceTranslatedAddress
about.nat_ip Merged
message
about.nat_ip Mapped: CEF: deviceTranslatedAddress
Emne
about.process.command_line Directly mapped
Path
about.process.command_line Directly mapped
Subject
about.process.command_line Directly mapped
deviceProcessName
about.process.command_line Renamed/mapped
dvcpid
about.process.pid Renamed/mapped
message
about.resource.attribute.permissions Mapped: CEF: permissions
permissions
about.resource.attribute.permissions Merged
additional_cfp1
additional.fields Merged
additional_cfp2
additional.fields Merged
additional_cfp3
additional.fields Merged
additional_cfp4
additional.fields Merged
additional_cn1
additional.fields Merged
additional_cn2
additional.fields Merged
additional_cn3
additional.fields Merged
additional_cs1
additional.fields Merged
additional_cs2
additional.fields Merged
additional_cs3
additional.fields Merged
additional_cs4
additional.fields Merged
additional_cs5
additional.fields Merged
additional_cs6
additional.fields Merged
additional_cs7
additional.fields Merged
additional_devicePayloadId
additional.fields Merged
additional_eventId
additional.fields Merged
additional_flexString1
additional.fields Merged
additional_fname
additional.fields Merged
cs2
additional.fields Mapped: arc_test additional_cs2
cs5_label
additional.fields Merged
description_url_label
additional.fields Merged
http_host_label
additional.fields Merged
log_id_field
additional.fields Merged
message
additional.fields Mapped values (27 total, e.g. CEF: sequencenum_label , CEF: additional_eventId , `...
originsicname_field
additional.fields Merged
reject_id_kid_field
additional.fields Merged
sequencenum_label
additional.fields Merged
ser_agent_kid_field
additional.fields Merged
version_field
additional.fields Merged
message
extensions.vulns.vulnerabilities Mapped: CEF: v
v
extensions.vulns.vulnerabilities Merged
int
intermediary Merged
message
intermediary Mapped: CEF: int
msg
metadata.description Directly mapped
Generated
metadata.event_timestamp Parsed as yyyy-MM-ddTHH:mm:ss
Received
metadata.event_timestamp Parsed as yyyy-MM-ddTHH:mm:ss
lastupdatetime
metadata.event_timestamp Parsed as UNIX
rt
metadata.event_timestamp Parsed as yyyy-MM-ddTHH:mm:ssZ
event_name
metadata.event_type Mapped: "LogSpyware","LogPredictiveMachineLearning" SCAN_UNCATEGORIZED
message
metadata.event_type Mapped: CEF: PROCESS_UNCATEGORIZED , CEF: SCAN_UNCATEGORIZED , CEF: → `NETWORK_C...
principal_machine_id_present
metadata.event_type Mapped: true NETWORK_CONNECTION
device_event_class_id
metadata.product_event_type Directly mapped
event_name
metadata.product_event_type Directly mapped
externalId
metadata.product_log_id Directly mapped
loguid
metadata.product_log_id Directly mapped
device_product
metadata.product_name Directly mapped
device_version
metadata.product_version Directly mapped
device_vendor
metadata.vendor_name Renamed/mapped
app_protocol_output
network.application_protocol Directly mapped
deviceDirection
network.direction Mapped: 0 INBOUND , 1 OUTBOUND
message
network.direction Mapped: CEF: INBOUND , CEF: OUTBOUND
requestMethod
network.http.method Renamed/mapped
requestClientApplication
network.http.user_agent Renamed/mapped
user_agent
network.http.user_agent Directly mapped
ip_protocol_out
network.ip_protocol Directly mapped
in
network.received_bytes Renamed/mapped
out
network.sent_bytes Renamed/mapped
session_id
network.session_id Directly mapped
sntdom
principal.administrative_domain Renamed/mapped
sourceServiceName
principal.application Renamed/mapped
Group_name
principal.group.group_display_name Directly mapped
Gruppenavn
principal.group.group_display_name Directly mapped
Device_name
principal.hostname Directly mapped
Enhetsnavn
principal.hostname Directly mapped
shost
principal.hostname Renamed/mapped
ip_proxy
principal.ip Merged
message
principal.ip Mapped: CEF: principal_ip , CEF: shost , CEF: ip_proxy
principal_ip
principal.ip Merged
shost
principal.ip Merged
mac
principal.mac Merged
message
principal.mac Mapped: CEF: mac
message
principal.nat_ip Mapped: CEF: sourceTranslatedAddress
sourceTranslatedAddress
principal.nat_ip Merged
sourceTranslatedPort
principal.nat_port Renamed/mapped
spt
principal.port Renamed/mapped
sproc
principal.process.command_line Renamed/mapped
spid
principal.process.pid Renamed/mapped
message
principal.user.attribute.roles Mapped: CEF: principal_role
principal_role
principal.user.attribute.roles Merged
suser
principal.user.user_display_name Directly mapped
suid
principal.user.userid Renamed/mapped
message
security_result Mapped: CEF: security_result
_action
security_result.action Merged
act
security_result.action Mapped: accept _action , deny _action
message
security_result.action Mapped: CEF: _action
Action_Taken
security_result.action_details Directly mapped
act
security_result.action_details Directly mapped
cat
security_result.category_details Merged
message
security_result.category_details Mapped: CEF: cat
Scan_Type
security_result.description Directly mapped
Type
security_result.description Directly mapped
msg_data_2
security_result.description Directly mapped
fn1
security_result.detection_fields Merged
fn2
security_result.detection_fields Merged
fs2
security_result.detection_fields Merged
ifname_label
security_result.detection_fields Merged
infection_channel_label
security_result.detection_fields Merged
layer_name_label
security_result.detection_fields Merged
layer_uuid_label
security_result.detection_fields Merged
message
security_result.detection_fields Mapped values (19 total, e.g. CEF: mitre_execution_label , CEF: ifname_label , `CE...
mitre_discovery_label
security_result.detection_fields Merged
mitre_execution_label
security_result.detection_fields Merged
operasjon_label
security_result.detection_fields Merged
operation_label
security_result.detection_fields Merged
permission_label
security_result.detection_fields Merged
policy_label
security_result.detection_fields Merged
policy_time_label
security_result.detection_fields Merged
smartdefense_profile_label
security_result.detection_fields Merged
spyware_Grayware_Type_label
security_result.detection_fields Merged
tags_label
security_result.detection_fields Merged
threat_probability_label
security_result.detection_fields Merged
tillatelse_label
security_result.detection_fields Merged
rule_uid
security_result.rule_id Directly mapped
mwProfile
security_result.rule_name Directly mapped
rule_name
security_result.rule_name Directly mapped
message
security_result.severity Mapped: CEF: LOW , CEF: MEDIUM , CEF: HIGH , CEF: CRITICAL
severity
security_result.severity Mapped: "0", "1", "2", "3", "LOW" LOW , `"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"...
Result
security_result.summary Directly mapped
appcategory
security_result.summary Directly mapped
reason
security_result.summary Renamed/mapped
Spyware
security_result.threat_name Directly mapped
Unknown_Threat
security_result.threat_name Directly mapped
Virus_Malware_Name
security_result.threat_name Directly mapped
oldFilePath
src.file.full_path Renamed/mapped
oldFileSize
src.file.size Renamed/mapped
message
src.resource.attribute.permissions Mapped: CEF: old_permissions
old_permissions
src.resource.attribute.permissions Merged
dntdom
target.administrative_domain Renamed/mapped
destinationServiceName
target.application Renamed/mapped
temp_dhost
target.hostname Directly mapped
IPv6_Address
target.ip Merged
dst_ip
target.ip Merged
ipv6
target.ip Mapped: - IPv6_Address
message
target.ip Mapped: CEF: dst_ip , CEF: IPv6_Address
mac_address
target.mac Merged
message
target.mac Mapped: CEF: mac_address
destination_translated_address
target.nat_ip Merged
message
target.nat_ip Mapped: CEF: destination_translated_address
destinationTranslatedPort
target.nat_port Renamed/mapped
dpt
target.port Renamed/mapped
dproc
target.process.command_line Renamed/mapped
File_name
target.process.file.full_path Directly mapped
Infected_Resource
target.process.file.full_path Directly mapped
Object
target.process.file.full_path Directly mapped
Objekt
target.process.file.full_path Directly mapped
dpid
target.process.pid Renamed/mapped
message
target.resource.attribute.labels Mapped: CEF: resource_Type_label
resource_Type_label
target.resource.attribute.labels Merged
request
target.url Directly mapped
message
target.user.attribute.roles Mapped: CEF: target_role
target_role
target.user.attribute.roles Merged
CustomerName
target.user.user_display_name Directly mapped
temp_duser
target.user.user_display_name Directly mapped
Bruker
target.user.userid Directly mapped
User_value
target.user.userid Directly mapped
temp_duid
target.user.userid Directly mapped
N/A
metadata.event_type Constant: PROCESS_UNCATEGORIZED
N/A
network.direction Constant: INBOUND
N/A
security_result.severity Constant: LOW

Need more help? Get answers from Community members and Google SecOps professionals.

Design a Mobile Site
View Site in Mobile | Classic
Share by: