Collect Trend Micro Email Security logs

Supported in:

This document explains how to ingest Trend Micro Email Security logs to Google Security Operations using Bindplane. Trend Micro Email Security is a cloud-based email gateway that protects organizations against spam, malware, phishing, ransomware, and advanced targeted attacks before they reach users' mailboxes. It provides URL filtering, attachment sandboxing, and data loss prevention for inbound and outbound email traffic.

Before you begin

Make sure you have the following prerequisites:

  • A Google SecOps instance.
  • A Windows 2016 or later or Linux host with systemd.
  • If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements.
  • Privileged access to the Trend Micro Email Security administration console.

Get Google SecOps ingestion authentication file

  1. Sign in to the Google SecOps console.
  2. Go to SIEM Settings > Collection Agent.
  3. Download the Ingestion Authentication File.

    • Save the file securely on the system where Bindplane will be installed.

Get Google SecOps customer ID

  1. Sign in to the Google SecOps console.
  2. Go to SIEM Settings > Profile.
  3. Copy and save the Customer IDfrom the Organization Detailssection.

Install the Bindplane agent

Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.

Windows installation

  1. Open the Command Promptor PowerShellas an administrator.
  2. Run the following command:

      msiexec 
      
     / 
     i 
      
     "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" 
      
     / 
     quiet 
     
    

Linux installation

  1. Open a terminal with root or sudo privileges.
  2. Run the following command:

     sudo  
    sh  
    -c  
     " 
     $( 
    curl  
    -fsSlL  
     [ 
    https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh ]( 
    https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh ) 
     )" 
      
    install_unix.sh 
    

Additional installation resources

For additional installation options, consult this installation guide .

Configure Bindplane agent to ingest syslog and send to Google SecOps

  1. Access the configuration file:

    • Locate the config.yaml file. Typically, it's in the /etc/bindplane-agent/ directory on Linux or in the installation directory on Windows.
    • Open the file using a text editor (for example, nano , vi , or Notepad).
  2. Edit the config.yaml file as follows:

      receivers 
     : 
      
     tcplog 
     : 
      
     # Replace the port and IP address as required 
      
     listen_address 
     : 
      
     "0.0.0.0:514" 
     exporters 
     : 
      
     chronicle/chronicle_w_labels 
     : 
      
     compression 
     : 
      
     gzip 
      
     # Adjust the path to the credentials file you downloaded in Step 1 
      
     creds_file_path 
     : 
      
     '/path/to/ingestion-authentication-file.json' 
      
     # Replace with your actual customer ID from Step 2 
      
     customer_id 
     : 
      
     YOUR_CUSTOMER_ID 
      
     endpoint 
     : 
      
     malachiteingestion-pa.googleapis.com 
      
     # Add optional ingestion labels for better organization 
      
     log_type 
     : 
      
     'TRENDMICRO_EMAIL_SECURITY' 
      
     raw_log_field 
     : 
      
     body 
      
     ingestion_labels 
     : 
     service 
     : 
      
     pipelines 
     : 
      
     logs/source0__chronicle_w_labels-0 
     : 
      
     receivers 
     : 
      
     - 
      
     tcplog 
      
     exporters 
     : 
      
     - 
      
     chronicle/chronicle_w_labels 
     
    
  • Replace the port and IP address as required in your infrastructure.
  • Replace YOUR_CUSTOMER_ID with the actual Customer ID.
  • Update /path/to/ingestion-authentication-file.json to the file path where the authentication file was saved in Step 1.

Restart the Bindplane agent to apply the changes

  1. To restart the Bindplane agent in Linux, run the following command:

     sudo  
    systemctl  
    restart  
    observiq-otel-collector 
    
  2. To restart the Bindplane agent in Windows, you can either use the Servicesconsole or enter the following command:

     net stop observiq-otel-collector && net start observiq-otel-collector 
    

Configure Trend Micro Email Security syslog forwarding

To configure Trend Micro Email Security to forward logs to the Bindplane agent via syslog, follow these steps:

  1. Sign in to the Trend Micro Email Securityadministration console.
  2. Go to Administration > Syslog Settings.
  3. Click Addto create a new syslog server profile.

  4. Provide the following configuration details:

    • Server Address: Enter the IP address of the Bindplane agent host (for example, 192.168.1.100 ).
    • Port: Enter 514 (or the port configured in the Bindplane agent).
    • Protocol: Select TCP.
    • Format: Select CEF(Common Event Format).
  5. In the Log Typessection, select the log categories to forward:

    • Policy Events- email filtering policy actions.
    • Spam Detection- spam and graymail events.
    • Malware Detection- virus and malware detection events.
    • Ransomware Detection- ransomware detection events.
    • URL Analysis- URL clicking and Time-of-Click protection events.
    • Advanced Threat Protection- sandbox analysis events.
    • Data Loss Prevention- DLP policy violation events.
    • Content Filtering- content filter rule events.
  6. Click Save.

  7. Click Test Connectionto verify that logs are being sent to the Bindplane agent.

  8. Verify logs are arriving by checking the Bindplane agent logs.

For more information, see the Trend Micro Email Security documentation .

UDM mapping table

Log Field UDM Mapping Logic
additional_cn1
additional.fields Merged
additional_cs1
additional.fields Merged
additional_cs2
additional.fields Merged
additional_cs3
additional.fields Merged
additional_cs4
additional.fields Merged
additional_cs5
additional.fields Merged
additional_cs6
additional.fields Merged
message
extensions.auth.type Mapped: login AUTHTYPE_UNSPECIFIED
msg
metadata.description Directly mapped
rt
metadata.event_timestamp Parsed as ISO8601
cs1
metadata.event_type Mapped: phishing SCAN_UNCATEGORIZED
message
metadata.event_type Mapped: CEF:0 GENERIC_EVENT , login USER_LOGIN
cs1
metadata.product_event_type Directly mapped
network_direction
network.direction Mapped: INCOMING INBOUND , OUTGOING OUTBOUND
cs2
principal.hostname Directly mapped
principal_ip
principal.hostname Directly mapped
principal_ip
principal.ip Merged
message
principal.user.userid Mapped: login target.user.userid
suser
principal.user.userid Directly mapped
act
security_result.action Mapped: ALLOW act , DENY security_result_action , QUARANTINE act
security_result_action
security_result.action Merged
act
security_result.action_details Directly mapped
cs5
security_result.rule_name Directly mapped
severity
security_result.severity Mapped: "0", "1", "2", "3", "LOW" LOW , `"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"...
cs6
target.url Directly mapped
duser
target.user.email_addresses Mapped: ; emailId
emailId
target.user.email_addresses Merged
duser
target.user.userid Directly mapped
principal.user.userid
target.user.userid Renamed/mapped
N/A
extensions.auth.type Constant: AUTHTYPE_UNSPECIFIED
N/A
metadata.event_type Constant: GENERIC_EVENT
N/A
network.direction Constant: INBOUND
N/A
principal.user.userid Constant: target.user.userid
N/A
security_result.severity Constant: LOW

Need more help? Get answers from Community members and Google SecOps professionals.

Create a Mobile Website
View Site in Mobile | Classic
Share by: